Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 9 months ago. Feb 02, 2017 - 11:39 EST
Identified
We are working to restore match making and logins for #Paladins #PC and #Smite #PC
Posted 9 months ago. Feb 02, 2017 - 11:31 EST
Investigating
Automated services have detected a possible problem with #SMITE PC and #PALADINS PC. We are investigating.
Posted 9 months ago. Feb 02, 2017 - 11:22 EST
This incident affected: Paladins PC.