Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #PaladinsPC
Posted 12 days ago. May 14, 2017 - 01:22 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 12 days ago. May 14, 2017 - 01:09 EDT
This incident affected: Paladins PC.