Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins PC has been resolved.
Posted 8 months ago. Apr 07, 2017 - 04:02 EDT
Monitoring
Restart of #Paladins PC is complete; we are continuing to monitor.
Posted 8 months ago. Apr 07, 2017 - 03:40 EDT
Identified
performing emergency restart of #Paladins PC; game back shortly; apologies for the inconvenience
Posted 8 months ago. Apr 07, 2017 - 02:26 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 8 months ago. Apr 07, 2017 - 02:04 EDT
This incident affected: Paladins PC.