Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved#Smite
Posted almost 2 years ago. Mar 09, 2016 - 14:35 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted almost 2 years ago. Mar 09, 2016 - 14:31 EST