Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This has been resolved.
Posted 11 days ago. Mar 15, 2017 - 18:36 EDT
Monitoring
Emergency restart of #SmitePS4 is complete; logins have been re-enabled; we are continuing to monitor.
Posted 11 days ago. Mar 15, 2017 - 15:45 EDT
Identified
We will be performing an emergency restart of #SmitePS4; game will be back shortly.
Posted 11 days ago. Mar 15, 2017 - 15:36 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 11 days ago. Mar 15, 2017 - 15:30 EDT
This incident affected: Smite PS4 - North America / Europe.