Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 14, 2016 - 08:32 EDT
Identified
We are aware of the issues effecting match making in #Paladins, we are working to resolve this issue.
Posted 10 months ago. Oct 14, 2016 - 08:06 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 10 months ago. Oct 14, 2016 - 07:53 EDT