Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite Xbox incident has been resolved.#smite
Posted 9 months ago. Nov 30, 2016 - 17:41 EST
Update
We are still investigating the Smite XBOX Issues #smite
Posted 9 months ago. Nov 30, 2016 - 17:36 EST
Update
We will be restarting Smite XBOX in 15 min#smite
Posted 9 months ago. Nov 30, 2016 - 16:15 EST
Update
Investigating: We are currently investigating this Smite XBOX issue.#smite
Posted 9 months ago. Nov 30, 2016 - 14:35 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 9 months ago. Nov 30, 2016 - 14:31 EST