Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Apr 14, 2016 - 16:09 EDT
Identified
We are working on resolving the issue with logins on #smite #xbox
Sorry for the inconvenience.
Posted about 1 year ago. Apr 14, 2016 - 16:04 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Apr 14, 2016 - 15:53 EDT