Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 12, 2017 - 22:15 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 8 months ago. Feb 12, 2017 - 22:06 EST