Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 2 months ago. Jan 11, 2017 - 09:56 EDT
Update
Currently looking into issues with SMITE PC. #SMITE
Posted 2 months ago. Jan 11, 2017 - 09:51 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 2 months ago. Jan 11, 2017 - 09:46 EDT
This incident affected: Smite PC - North America / Europe.