Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Paladins PC incident has been resolved. #PaladinsPC
Posted 6 months ago. Feb 21, 2017 - 20:37 EST
Identified
Steam is undergoing routine maintenance. https://steamstat.us #Paladins PC
Posted 6 months ago. Feb 21, 2017 - 20:09 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 6 months ago. Feb 21, 2017 - 19:56 EST