Steam Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issues effecting Smite Steam clients have been resolved.
Posted over 1 year ago. Jun 14, 2016 - 21:21 EDT
Investigating
We are currently aware of the client issue effecting Steam.
We should be resolving this issue shortly.
Sorry for the inconvenience.
Posted over 1 year ago. Jun 14, 2016 - 20:36 EDT