Paladins PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins #PC has been resolved.
Posted Sep 15, 2017 - 21:10 EDT
Monitoring
The restart of #Paladins #PC has been completed. We are monitoring the results.
Posted Sep 15, 2017 - 20:46 EDT
Identified
We are performing an emergency restart of #Paladins #PC at 7:55PM EST
Posted Sep 15, 2017 - 19:45 EDT
This incident affected: Paladins (Paladins PC).