Smite PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Feb 01, 2017 - 16:15 EST
Investigating
We will be performing and emergency restart of #Smite #PC
Posted 10 months ago. Feb 01, 2017 - 15:58 EST
This incident affected: Smite PC - North America / Europe.