Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 days ago. Dec 06, 2017 - 15:33 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 days ago. Dec 06, 2017 - 15:06 EST
Identified
We have identified the issue and will be performing an emergency restart for Paladins PC in a moment
Posted 6 days ago. Dec 06, 2017 - 14:58 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 6 days ago. Dec 06, 2017 - 14:53 EST