Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This SmitePC incident has been resolved. # SmitePC
Posted about 2 months ago. Feb 26, 2017 - 18:31 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 2 months ago. Feb 26, 2017 - 18:21 EST
This incident affected: Smite PC - North America / Europe.