Paladins PC Matches Launching
Incident Report for Hi-Rez Studios, Inc
Resolved
Issues impacting #Paladins PC have been resolved. Matches are launching and Logins have stabilized
Posted 9 months ago. Oct 30, 2016 - 09:38 EDT
Monitoring
Match making and login issues impacting #Paladins PC have been corrected; we are continuing to monitor the situation.
Posted 9 months ago. Oct 30, 2016 - 09:27 EDT
Investigating
We are aware of and investigating an issue with #Paladins PC with matches launching.
Posted 9 months ago. Oct 30, 2016 - 09:10 EDT