Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Smite PS4incident has been resolved. #SmitePS4
Posted 4 months ago. Mar 18, 2017 - 06:34 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 4 months ago. Mar 18, 2017 - 05:39 EDT