Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Paladins PC incident has been resolved. #PaladinsPC
Posted 3 months ago. May 09, 2017 - 13:06 EDT
Monitoring
A fix has been implemented and we are monitoring the results. #PaladinsPC
Posted 3 months ago. May 09, 2017 - 12:33 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 3 months ago. May 09, 2017 - 12:25 EDT