Pausing Smite PC Logins for a few minutes... Sorry for the inconvenience
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved# smitepc
Posted 4 months ago. Feb 04, 2017 - 12:59 EST
Update
We will be restarting Smite PC in 5 min # SmitePC
Posted 4 months ago. Feb 04, 2017 - 11:49 EST
Investigating
Pausing Smite PC Logins for a few minutes... Sorry for the inconvenience #smitepc
Posted 4 months ago. Feb 04, 2017 - 10:35 EST
This incident affected: Smite PC - North America / Europe.