Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite XBox restart has been completed
Posted 18 days ago. Nov 24, 2017 - 21:45 EST
Identified
We will be restarting Smite XBox momentarily
Posted 18 days ago. Nov 24, 2017 - 21:30 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 18 days ago. Nov 24, 2017 - 21:25 EST