Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 18 days ago. Mar 09, 2017 - 00:08 EDT
Monitoring
We are currently monitoring the SMITE XBOX environment. #SMITE #XBOX
Posted 18 days ago. Mar 08, 2017 - 23:39 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 18 days ago. Mar 08, 2017 - 23:23 EDT
This incident affected: Paladins Xbox.