Smite PC Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jun 16, 2018 - 13:56 EDT
Update
Chat and Friends lists for #Smite #PC are back up. Players will need to log out and back in for them to show up.
Posted Jun 16, 2018 - 13:20 EDT
Monitoring
Restart has been completed and logins have resumed. We are keeping a close eye on things.
Posted Jun 16, 2018 - 12:41 EDT
Identified
We are performing an emergency restart for Smite PC
Posted Jun 16, 2018 - 12:22 EDT
Investigating
We are looking into the issue affecting #Smite #PC.
Posted Jun 16, 2018 - 12:21 EDT
This incident affected: SMITE (SMITE PC).