Xbox Live Reporting Purchasing and Content Usage Outage
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with purchasing and content usage has been resolved. https://bit.ly/1GKcuPr
Posted 2 months ago. May 10, 2018 - 23:22 EDT
Monitoring
Xbox Live is reporting an outage with their purchasing and content usage services, which may affect #Smite, #Paladins, and #HotG purchases and DLC. Xbox Live status: https://bit.ly/1GKcuPr
Posted 2 months ago. May 10, 2018 - 21:49 EDT
This incident affected: Paladins (Paladins Xbox), Hand of the Gods (Hand of the Gods Xbox), and Smite (Smite Xbox).