Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC has returned to normal; we apologize for the inconvenience.
Posted Apr 28, 2017 - 20:57 EDT
Monitoring
Emergency restart of #SMITE PC is complet; game is back; we are continuing to monitor.
Posted Apr 28, 2017 - 20:29 EDT
Identified
We will be performing an emergency restart of #SMITE PC; game back shortly.
Posted Apr 28, 2017 - 20:15 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted Apr 28, 2017 - 20:07 EDT
This incident affected: SMITE (SMITE PC).