Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have resolved the issue effecting logins and disconnections.
Posted 9 months ago. Jun 14, 2016 - 11:03 EDT
Identified
We are currently investigating the issues with disconnections and logins across our game services.
Sorry for the inconvenience.
Posted 9 months ago. Jun 14, 2016 - 10:23 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted 9 months ago. Jun 14, 2016 - 10:16 EDT