Smite PS4 restart
Incident Report for Hi-Rez Studios, Inc
Resolved
We have finished restarting Smite Ps4#smite
Posted 9 months ago. Jun 23, 2016 - 04:00 EDT
Update
We are restarting Smite PS4 now#smite
Posted 9 months ago. Jun 23, 2016 - 03:50 EDT
Investigating
We are restarting Smite PS4 in 15 min#smite
Posted 9 months ago. Jun 23, 2016 - 03:35 EDT