Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issues with #PALADINS #PC have been resolved.
Posted 5 months ago. May 10, 2017 - 22:55 EDT
Identified
We are currently looking into issues with #PALADINS #PC
Posted 5 months ago. May 10, 2017 - 22:36 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 5 months ago. May 10, 2017 - 22:31 EDT
This incident affected: Paladins PC.