Smite PS4 Limiting Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have been resumed on #SMITE PS4; we are continuing to monitor but believe the issue to be resolved.
Posted about 1 month ago. Feb 17, 2017 - 13:11 EST
Investigating
We are limiting logins for SMITE PS4 to look into issues with the enviroment. #SMITE PS4
Posted about 1 month ago. Feb 17, 2017 - 12:34 EST
This incident affected: Smite PS4 - North America / Europe.