Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The situation has been resolved and we will continue to monitor.
Posted about 2 months ago. Oct 07, 2017 - 17:54 EDT
Monitoring
We are currently monitoring the situation.
Posted about 2 months ago. Oct 07, 2017 - 17:43 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 2 months ago. Oct 07, 2017 - 17:29 EDT
This incident affected: Smite Xbox - North America / Europe.