Matches not launching on Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have resumed and Instances should be launching normally on #Smite.
Posted 7 months ago. Sep 10, 2016 - 22:24 EDT
Investigating
We are currently working to resolve the issues associated with matches not launching.
We apologize for the inconvenience.
#Smite
Posted 7 months ago. Sep 10, 2016 - 22:02 EDT