Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 02, 2017 - 14:35 EST
Identified
We are currently working to restore connectivity to our game services.
Posted 4 months ago. Feb 02, 2017 - 14:17 EST
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted 4 months ago. Feb 02, 2017 - 14:16 EST
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, Smite PS4 - North America / Europe, and Paladins PC.