Paladins PC Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issues with Paladins PC have been resolved.
Posted 3 months ago. Jan 16, 2017 - 12:37 EST
Investigating
We are currently looking into Paladins PC issue. #Paladins
Posted 3 months ago. Jan 16, 2017 - 12:31 EST
This incident affected: Paladins PC.