Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This smite ps4 incident has been resolved. #smiteps4
Posted 3 months ago. May 08, 2017 - 03:54 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 3 months ago. May 07, 2017 - 23:34 EDT
This incident affected: Smite PS4 - North America / Europe.