Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue with #Paladins PC has been resolved.
Posted 3 months ago. May 16, 2017 - 00:52 EDT
Update
We have corrected an issue with #Paladins PC that resulted in player drops; we are continuing to monitor...
Posted 3 months ago. May 16, 2017 - 00:18 EDT
Monitoring
We have corrected an issue with #Paladins PC that resulted in a drop in connected players; we are continuing to monitor.
Posted 3 months ago. May 16, 2017 - 00:18 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 3 months ago. May 16, 2017 - 00:08 EDT
This incident affected: Paladins PC.