Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#paladins issues with Steam DoS resolved. Continuing to monitor.
Posted 7 months ago. Dec 23, 2016 - 15:29 EST
Identified
Steam Service is currently experiencing issues. We are monitoring. #PALADINS
Posted 7 months ago. Dec 23, 2016 - 10:43 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 months ago. Dec 23, 2016 - 10:35 EST
This incident affected: Paladins PC.