Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PS4 incident has been resolved#smite
Posted almost 2 years ago. May 25, 2016 - 21:32 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted almost 2 years ago. May 25, 2016 - 21:23 EDT