Disconnections
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Hirez Games incident has been resolved.#paladins#tribes#smite
Posted almost 2 years ago. Jul 11, 2016 - 15:27 EDT
Investigating
We are currently investigating the recent disconnections in our game environments.
Sorry for the inconvenience.
Posted almost 2 years ago. Jul 11, 2016 - 15:11 EDT