Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue impacting #Paladins PC has been resolved; we apologize for the inconvenience.
Posted about 2 months ago. May 13, 2017 - 17:39 EDT
Monitoring
We have identified and addressed an issue with #Paladins PC that resulted in player disconnects. We are continuing to monitor. Game should be back to normal shortly.
Posted about 2 months ago. May 13, 2017 - 17:04 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. May 13, 2017 - 16:31 EDT
This incident affected: Paladins PC.