Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins #PC has been resolved.
Posted 18 days ago. Nov 24, 2017 - 12:51 EST
Update
We are performing an emergency restart of #Paladins #PC. The game will be back up shortly.
Posted 18 days ago. Nov 24, 2017 - 12:30 EST
Identified
We are temporarily limiting logins to address an issue in #Paladins #PC.
Posted 18 days ago. Nov 24, 2017 - 12:13 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 18 days ago. Nov 24, 2017 - 11:52 EST
This incident affected: Paladins PC.