Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 14, 2016 - 16:38 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted over 1 year ago. Aug 14, 2016 - 16:19 EDT