Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved. #SMITEXBOX
Posted 5 months ago. May 07, 2017 - 02:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results #SMITEXBOX
Posted 5 months ago. May 07, 2017 - 01:55 EDT
Update
We are currently investigating this issue. #SmiteXBox
Posted 5 months ago. May 07, 2017 - 01:48 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 5 months ago. May 07, 2017 - 01:28 EDT