Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 6 months ago. Jan 08, 2017 - 21:02 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 6 months ago. Jan 08, 2017 - 20:59 EST
This incident affected: Smite Xbox - North America / Europe.