Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #paladinspc
Posted 4 months ago. Feb 27, 2017 - 01:30 EST
Identified
Pausing logins for a few moments to restart a component of the game. #paladinsPC
Posted 4 months ago. Feb 27, 2017 - 01:24 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 4 months ago. Feb 27, 2017 - 01:16 EST
This incident affected: Paladins PC.