Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 13, 2017 - 22:35 EST
Monitoring
Services have been restored, we are continuing to monitor #Paladins #PC
Posted 3 months ago. Jan 13, 2017 - 19:53 EST
Identified
We are currently working to restore services to #Paladins #PC.
Posted 3 months ago. Jan 13, 2017 - 19:32 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 3 months ago. Jan 13, 2017 - 19:28 EST
This incident affected: Paladins PC.