Console Emergency Downtime
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 12 days ago. Jun 12, 2018 - 13:37 EDT
Identified
We will be bringing down all console environments momentarily to fix a server issue.
Posted 12 days ago. Jun 12, 2018 - 13:17 EDT
This incident affected: Hand of the Gods (Hand of the Gods PS4, Hand of the Gods Xbox) and Paladins (Paladins PS4, Paladins Xbox).