Smite Xbox Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue with #Smite #Xbox has been resolved.
Posted 17 days ago. Jun 07, 2018 - 17:26 EDT
Monitoring
The emergency restart for #Smite #Xbox has been completed. We are monitoring the results.
Posted 17 days ago. Jun 07, 2018 - 16:59 EDT
Update
We are performing an emergency restart for #Smite Xbox. The game will be back up soon.
Posted 17 days ago. Jun 07, 2018 - 16:44 EDT
Identified
We are temporarily limiting logins for #Smite #Xbox to address an issue.
Posted 17 days ago. Jun 07, 2018 - 16:35 EDT
Investigating
We are currently investigating an issue with #Smite #Xbox.
Posted 17 days ago. Jun 07, 2018 - 16:30 EDT
This incident affected: Smite (Smite Xbox).