network issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 27, 2015 - 21:31 EDT
Identified
we are currently experiencing network issues
Posted over 1 year ago. Aug 27, 2015 - 20:33 EDT