Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We restarted a component of the game
Posted almost 2 years ago. Feb 16, 2016 - 13:07 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted almost 2 years ago. Feb 16, 2016 - 12:42 EST