Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #smite
Posted 9 months ago. Jul 05, 2016 - 01:05 EDT
Update
We are currently experiencing issues with purchases on pc, we are working to fix the issue.#smite
Posted 9 months ago. Jul 05, 2016 - 00:22 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 9 months ago. Jul 04, 2016 - 23:54 EDT